vim及插件编译

VIM编译

编译选项

--with-features=huge

--enable-multibyte

--enable-rubyiniterp

--enable-pythoninterp

--with-python-config-dir=/usr/lib/python2.7/config-x86_64-linux-gnu/

--enable-python3interp

--with-python3-config-dir=/usr/lib/python3.7/config-3.7m-x86_64-linux-gnu/

--enable-luainterp

--enable-cscope

--enable-perlinterp

--prefix=~/.local

./configure --with-features=huge --enable-multibyte --enable-rubyiniterp --enable-pythoninterp --with-python-config-dir=/usr/lib/python2.7/config-x86_64-linux-gnu/ --enable-python3interp --with-python3-config-dir=/usr/lib/python3.7/config-3.7m-x86_64-linux-gnu/ --enable-luainterp --enable-cscope --enable-perlinterp --prefix=/home/frey/.local
make -j8
make install

错误

You need to install a terminal library; for example ncurses
安装libncurse5-dev可以解决

apt install libncurse5-dev

YouCompleteMe编译

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注