树莓派4B安装raspberrypi系统后,用自带的源安装docker,在涉及到libseccomp这个库时会报错

-------------------------------------
          _         ()
         | |  ___   _    __
         | | / __| | |  /  \
         | | \__ \ | | | () |
         |_| |___/ |_|  \__/

Brought to you by linuxserver.io
-------------------------------------
To support LSIO projects visit:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------
User uid:    1000
User gid:    1000
-------------------------------------
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Your DockerHost is running an outdated version of libseccomp
To fix this, please visit https://docs.linuxserver.io/faq#libseccomp
Apps will not behave correctly without this
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

具体原因是由于libseccomp2库的一些bug,已经修复但没有被推送到所有仓库,在这里有一些解释。也介绍了一些措施去修复。

尝试后并没有用,可能是某些步骤错了。

最后通过重新安装docker解决了

sudo apt remove docker.io
sudo apt autoremove
sudo apt update
sudo apt upgrade
curl -fsSL https://get.docker.com -o get-docker.sh
sudo sh get-docker.sh
systemctl start docker

docker官方下载的安装脚本get-docker.sh会给apt添加一个新的源,并从docker的官方源重新安装docker的最新版本。

参考

  1. FAQ – LinuxServer.io

最后修改日期: 2022-04-12